Tag Archives: computer

The cyber side of cyberbee

The current hardware for running cyberbee.net, you will be surprised to find out:

CPU: AMD Athlon(tm) Processor (950.04-MHz 686-class CPU)
real memory = 402587648 (393152K bytes)

It worked perfectly fine with html and jpeg files. But when I was playing with WordPress, it required mysql and suddenly even a Pentium 4 at 2.4GHz did it very slowly in loading the page. I tested it on a 4 core AMD and it seemed much faster ($400 parts and I built it). So yesterday (March 26) I ordered the following new hardware:

1. Motherboard: Biostar TA790GX A3+, AM3 128MB DDR2 Side-Port, ATI Hybrid CrossFire, PCIe 2.0, Gigabit, USB2.0, RAID, HDMI, DVI, VGA. It is supposed to be compatible with the Linux flavor I am running, but I will see.

2. CPU: AMD Phenom II X4 955 Black Edition AM3 CPU HDZ955FBGMBOX – 3.20GHz, Socket AM3, 6MB Cache, 2000MHz (4000 MT/s) FSB, Retail, Processor with Fan. This baby has 4 CPUs, each running at 10x faster than my previous one…

3. Memory: Corsair PC12800 RAM – 4GB, DDR3, 1600MHz, Core i5, Dual Channel, Class 9. DDR3 is quite expensive compared to DDR2 (which I bought 8 gb for $150 last time), so I am settling for 4 instead of 8 gb.

4. Harddrives: 2 of Hitachi 1000Gb Serial ATA HD 7200/32MB/SATA-3G. I want to set up a RAID-1 which will have two drives with identical information, so if one fails, the other one can take over without restoring from backup.

All these “cutting edge” hardware for very little $. In fact, The item 1+2 was priced at $290, I negotiated down to $275, and today (one day after my order!) the price became $273.


postscript: my mysql backup software was not working very well! I was trying to add something to the kernel because fail2ban (another script to stop hacking through other venues, denyhosts only stops sshd password guessing) was not working (requires ALTQ, which has to be in a custom-rebuilt kernel), rebooted this morning and lost all the info! (root password was reset, users gone). I restored a copy of mysql backup last night (4 am automatically by a cron script), but it did not have the 2 posts I made yesterday! what is going on? I am glad at least I have most of the contents though.